Search the web with Google

Android install

Android installation weblog


Enter your email address:


Jeroen´s weblog

Ubuntu install

Ubuntu installation weblog


Thursday, January 27, 2011

Replace OpenOffice with Libre Office in Ubuntu 10.10

1. Remove all instances of OpenOffice.
Open a terminal and type:
sudo apt-get autoremove openoffice.org-*

2. Install LibreOffice via PPA
sudo add-apt-repository ppa:libreoffice/ppa
sudo apt-get update
sudo apt-get install libreoffice

Note: The version listed in the PPA is still RC4, but it is exactly the same as the final version.

Those who are using Gnome can install the Gnome package for better backend integration
sudo apt-get install libreoffice-gnome

To enable PDF import capability:
sudo apt-get install libreoffice-pdfimport

To enable English spellcheck capability
sudo apt-get install language-support-en

To enable Dutch spellcheck capability
sudo apt-get install language-support-nl

Enjoy!

12 comments:

Robert said...

Thanks for showing me how to install LibreOffice in Ubuntu. Worked with no issues.

Newbie Author said...

Great! Now I have Libre-Office. Your instructions were simple and worked perfectly.

Thanks.

Michael Groves said...

Great howto!

Thank you much.

grover66

Phil1581 said...

Thanks - another linux hurdle passed.

Erama said...

Gracias! funciono perfecto!

spera said...

Thanks a lot-after removing open office & with Libreoffice my PC is much faster

papseddy said...

nice upgrade solution........ thankz a lot

kobebintang said...

it worked, thx. Mauliate godang, horas !!

vladimiro said...

Perfect. Thank's!!

Lars Qvist said...

Thank you!

Deepak said...

Worked perfectly well...

simple and fast to install...

great job...

Otto Elter said...

Hi I got the following:


sudo apt-get install libreoffice
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libreoffice: Depends: libreoffice-core (= 1:3.5.4-0ubuntu1~lucid1) but it is not going to be installed
Depends: libreoffice-writer but it is not going to be installed
Depends: libreoffice-calc but it is not going to be installed
Depends: libreoffice-impress but it is not going to be installed
Depends: libreoffice-draw but it is not going to be installed
Depends: libreoffice-math but it is not going to be installed
Depends: libreoffice-base but it is not going to be installed
Depends: libreoffice-filter-mobiledev but it is not going to be installed
Depends: libreoffice-java-common (>= 1:3.5.4~) but it is not going to be installed
Recommends: libreoffice-gnome but it is not going to be installed or
libreoffice-kde but it is not going to be installed

Post a Comment