Search the web with Google

Android install

Android installation weblog


Enter your email address:


Jeroen´s weblog

Ubuntu install

Ubuntu installation weblog


Saturday, March 12, 2011

DeltaDIO (Envy24)

Automatic sound card detection isn't able to configure the
Delta card correctly, the card seems to be a bit too exotic
for that. So I'd say it's a HAL and/or PulseAudio problem.

Since the configuration process succesfully manages to open
the device - after much struggling - you probably can make
it work with static device configuration. The thing that the
configuration finally stumbles is that the channel map for
the sink and source aren't valid. That's because there isn't
a default channel map defined for 10 and 12 channels.

So, what you'll have to do is edit /etc/pulse/default.pa.
Comment out module-hal-detect and module-detect, and then
add these lines (if you don't need the sources, leave them
out):

# Load the on-board device:
load-module module-alsa-sink sink_name=intel-hda_out device=hw:0
load-module module-alsa-source source_name=intel-hda_in device=hw:0

# Load Delta 44:
load-module module-alsa-sink sink_name=delta_out device=hw:1 channels=10 channel_map=left,right,aux0,aux1,aux2,aux3,aux4,aux5,aux6,aux7
load-module module-alsa-source source_name=delta_in device=hw:1 channels=12 channel_map=left,right,aux0,aux1,aux2,aux3,aux4,aux5,aux6,aux7,aux8,aux9

# Set the default sink and source (not mandatory, intel-hda
# would probably be used without this):
set-default-sink
delta_out set-default-source delta_in


That configuration makes Delta a stereo device, in the sense
that if you play surround content, there will be sound only
in the first two channels. If you want a surround setup (or
want to have the stereo output on some other physical
connector(), edit the channel maps. Valid channel names are
listed in near the beginning of this page (under the "Device
Drivers" heading):

http://www.pulseaudio.org/wiki/Modules

If you wonder why I didn't set the 'channels' argument of
Delta to 2, that's because it seems that the device can't be
opened for just two channels. The auto-configurator managed
to open the device with 10 out and 12 in channels, that's
why I'm using those values.

This setup makes the assumption that the on-board device
will always be hw:0 and Delta will be hw:1. This isn't
necessary a valid assumption.

No comments:

Post a Comment