Search the web with Google

Android install

Android installation weblog


Enter your email address:


Jeroen´s weblog

Ubuntu install

Ubuntu installation weblog


Friday, March 18, 2011

Shotwel update in Lucid Lynx

 
Shotwell is the default photo manager for Ubuntu. In order to get updates to the app, you need to use the PPA. The creators of Shotwell will not push the newest version, 0.8, to their PPA. The reason for this is as follows.
It turns out we can't easily release Shotwell 0.8 for Lucid in the Yorba PPA.  The problem is that Lucid has only Vala 0.8, but Shotwell requires Vala 0.10 to build.  We can't pull in Vala from the Vala PPA, because that would give us version 0.11, which can't be used to build Shotwell either (see #2638).  There's no easy workaround, so I'm marking this as wontfix.
Fortunately Martin Wimpress has provided an alternative PPA for Lucid users. He created a PPA containing the latest version. Martin points out you can Shotwell in many other PPAs, but they contain many other applications. This PPA does not contain any other apps. There are dependencies from the Yorba PPA so you need that PPA too.

To install the PPA, run the following commands

sudo apt-add-repository ppa:yorba/ppa
sudo apt-add-repository ppa:flexiondotorg/shotwell
sudo apt-get update
sudo apt-get install shotwell

No comments:

Post a Comment